• 欢迎访问显哥博客,本网站纯属学习技术,绝无商业用途,欢迎小伙伴们共同学习!研究技术!QQ:52249909 加我QQ
  • 世界75亿人,这么小的概率,能认识你,是我一生的幸运,不妨加个QQ接触一下:52249909 加我QQ

Centos7 yum安装php5.6版本【显哥出品,必为精品】

技术栈 lixian 7个月前 (03-16) 776次浏览 0个评论 扫描二维码
文章目录[隐藏]

前言

centos7默认使用yum install 来安装程序,但默认源安装的php是5.4的,版本比较低,

要安装高版本的,要么下载源代码手动编译安装,但对不熟悉的,万一出点错误,会越搞越乱。我一般使用epel源安装php,里面各个版本都有,最新的php7.3

安装php5.6

1.首先安装epel

rpm -ivh https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-13.noarch.rpm

这里面的url是目前我用的,如果提示出错,就是换url了,可以在电脑上手动打开epel源列表 去检查 epel-release是哪个版本,换上对应的名字
https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/

2.按版本安装php

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
 
yum install php56w php56w-mysql php56w-pdo php56w-gd php56w-ssl php56w-mbstring php56w-cli php56w-xml php56w-bcmath

我这里列的是一些常用的php扩展,如果需要其它的,手动加上即可

如果需要安装php其它版本,把包名里的56改成对应版本即可 ,如

yum install php71w php71w-mysql php71w-pdo php71w-gd php71w-ssl php71w-mbstring php71w-cli php71w-xml php71w-bcmath
 
yum install php72w php72w-mysql php72w-pdo php72w-gd php72w-ssl php72w-mbstring php72w-cli php72w-xml php72w-bcmath

可对应安装php7.1和php7.2,这种安装方法,会默认配置好对应的设置,php.ini在/etc/中查找,命令行也默认启用了 (php-cli)


本站博主 , 版权所有丨如未注明 , 均为原创
转载请注明原文链接:Centos7 yum安装php5.6版本【显哥出品,必为精品】
喜欢 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到