• 欢迎访问显哥博客,本网站纯属学习技术,绝无商业用途,欢迎小伙伴们共同学习!研究技术!QQ:52249909 加我QQ
  • 世界75亿人,这么小的概率,能认识你,是我一生的幸运,不妨加个QQ接触一下:52249909 加我QQ

解决WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录凭据以继续。

WordPress lixian 2年前 (2020-01-09) 1399次浏览 4个评论 扫描二维码
文章目录[隐藏]

WordPress安装插件或主题报错

在服务器安装wordpress 后,在后台自动升级时,或者更新、删除主题或者插件的时候,如果提示需要输入FTP账户信息,然而即使我们正确输入了FTP用户名和密码也无法完成升级,这个是服务器端的权限设置问题,不是用户的问题。
解决WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录凭据以继续。

解决

可以在wordpress安装路径下的配置文件wp-config.php的最后加入下面代码:

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

问题就得到了解决。

上述代码实际上是为WordPress更新或下载插件时,提供了权限。


本站博主 , 版权所有丨如未注明 , 均为原创
转载请注明原文链接:解决WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录凭据以继续。
喜欢 (53)
lixian
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到
(4)个小伙伴在吐槽
  1. very nice blog af62fod23441k83b
    匿名2021-05-14 08:57 回复
  2. 按照博主的方式修改了配置文件,再次升级还是需要登录ftp这些。请问是要重启什么么?
    匿名2021-04-13 01:38 回复
    • lixian
      重启一下php差不多就好了 我之前没有写需要重启应该不会重启呀!你先试一下重启php好不好使
      lixian2021-04-13 08:42 回复